Mélange de versions de Moodle détectées. La mise à jour ne peut pas être poursuivie

La mise à jour de Moodle a été interrompue, car des fichiers PHP d'au moins deux versions majeures différentes de Moodle ont été détectés dans le dossier Moodle.

Cette situation pourrait causer ultérieurement de graves problèmes. Pour cette raison, afin de continuer la mise à jour, vous devez vous assurer que le dossier Moodle ne contient que des fichiers d'une seule version de Moodle.

Pour nettoyer votre dossier Moodle, il est recommandé d'agir ainsi :

  • renommer votre dossier Moodle en « moodle_old »;
  • créer un nouveau dossier Moodle ne contenant que les fichiers provenant soit de la distribution standard de Moodle préalablement téléchargée, soit du dépôt Git de Moodle ;
  • déplacer le fichier config.php et tous les plugins non-standards du dossier « moodle_old » vers le nouveau dossier Moodle.

Une fois votre dossier Moodle nettoyé, rafraîchissez l'affichage de cette page pour reprendre le processus de mise à jour de Moodle.

Cet avertissement s'affiche le plus souvent suite au dé-compactage d'une archive ZIP standard de Moodle par-dessus une version existante de Moodle. Ce procédé est valable pour les mises à jour mineures. Il est en revanche vigoureusement déconseillé pour les mises à jour majeures de Moodle.

L'avertissement peut également être causé par la mise à jour incomplète d'un dépôt Git. Dans ce cas, attendez la fin de la mise à jour, lancez une commande adéquate pour nettoyer le dossier et réessayez l'opération.

Vous trouverez plus d'informations à ce sujet dans la documentation de mise à jour ici : http://docs.moodle.org/34/fr/Upgrading